


SCIENCE/REFERENCE 

0 
NE OF THE GREATEST CHALLENGES facing atmospheric science instructors is 

helping students link theoretical and mathematical concepts to the real atmosphere. 

The past decade has been characterized by remarkable advances in meteorological 

observation, computing techniques, and data-visualization technology. However, the benefit of 

these advances can only be fully realized with the introduction of a systematic, applied approach 

to meteorological education that allows well-established theoretical concepts to be used with 

modernized observational and numerical datasets. This lab manual is a tool designed just for this 

purpose; it links theoretical concepts with groundbreaking visualization to elucidate concepts 

taught in the award-winning companion textbook by Gary Lackmann, Midlatitude Synoptic 

Meteorology. When used in concert with Lackman n's book and the companion CD of lecture 

slides, this lab manual will guide students in using contemporary observational and visualization 

techniques to provide in-depth understanding of fundamental concepts and serve as a catalyst 

for student-led innovation and application. With topics considered in an order that reinforces and 

builds upon new knowledge in meteorological observation and analysis, these materials will help 

students to deepen their understanding and put this understanding into practice. 
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About This Manual 

This laboratory manual is organized in parallel to the Midlatitude Synoptic Meteorology 
(MSM; Lackmann 2011) textbook, with lessons and activities for many of the main chap

ters of the text. For brevity, the activities in this manual will repeat only a little of the MSM 

material, but it will be assumed that students undertaking the lab exercises are familiar 

with the background concepts, drawn from MSM or elsewhere. 

Some of the lessons in this manual are on-paper exercises, involving only sketching, writ

ing answers and explanations, or writing brief mathematical derivations. Others are data 
exercises, which must be done on a computer. 

Software for these data exercises must perform a diverse set of tasks, ranging from multi

source data access ( e.g., from directories on a single computer or a local area network, and 

from remotely accessible data catalogs), to meteorology-specific displays (e.g., horizon-

tal "plan-view" maps and RAOB soundings), to remotely sensed imagery (e.g., satellite 

and radar displays), to analysis and 3D visualization of gridded output from numerical 

models. For these reasons, we chose to base the exercises mainly on the Integrated Data 
Viewer (IDV), developed and maintained by Unidata. Unidata is one of the programs 

within the non-profit University Corporation for Atmospheric Research, funded since 

the 1980s by the U.S. National Science Foundation to "democratize" access to weather 

data. With that long history, their software is very mature and well-designed, and remains 

actively supported by both dedicated personnel at Unidata and the open-source software 
developer community worldwide. 

The IDV is a free, easy-to-install, open-source application. Written in the Java program

ming language, it runs on all contemporary computer operating systems. It reads from 
( and can write to) data files and catalogs stored on remote servers, or locally on a user's 

computer. It features a powerful array of diagnostic and visualization capabilities, includ
ing meteorology-specific special displays. Displays in IDV are inherently three-dimen

sional, although we often use simple "plan views" ( on a flattened Earth map, viewed from 

above). Of course the vertical coordinate is greatly exaggerated in 3D synoptic displays: 

the troposphere is really thinner than an onion's skin, in a relative sense. The IDV remains 

under active development by Unidata staff, with input from its user community (which 

includes the authors and users of this manual!), so please feel free to send us (and/or Uni
data) suggestions and feedback. 

Each exercise in this manual uses these typefaces for clarity: 

Normal typeface is used for background information, technical instructions, motivating 
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questions, and learning objectives. Bold indicates assigned actions and questions that 

students are expected to respond to in their report. A constant width typeface 

is used to indicate text that can be found exactly on the IDV software ( usually on the 

Dashboard, Map, or Globe view windows, and display Legend areas). 

The word Optional: is used to set off suggestions for further explorations, which may be 
conceptual, or involve alternative data sources. For instance, in some exercises, the IDV 

can be dialed back to arbitrary dates to examine past archival cases, or real-time data can 

be examined with lookalike displays identical to the lesson's example. 

This typeface convention is repeated on the introductory page of each chapter. 

Introduction to the Integrated Data Viewer (IDV) 

To use this manual, you will need to install and test this free software, and install a few 

plug-ins for additional functionality. The main Unidata IDV web page* gives its overview. 
The IDV is open-source, free software; its installation involves just a few clicks and a min

imal registration process. The download link is easily found on the main IDV web page 

referenced above. Students should be encouraged to install it on their own computers as 

well. The IDV is memory intensive: to perform well, a computer should have at least 4GB 

of RAM, preferably more ( especially given the relatively high memory demands of current 

computer operating systems). Other large applications and multiple web browser tabs 

and/ or windows should be closed to conserve memory. Efficiency tweaks in recent IDV 

versions have made this less of a problem, happily. 

Please refer to Appendix 1 of this manual to orient your expectations. The IDV is profes
sional scientific software, which we liken to a workshop full of sharp and powerful tools, 

often without blade guards. Many pitfalls and frustrations await a careless approach to 
such a workshop! In the age of commercial software, students may be accustomed to pok

ing at buttons thoughtlessly or impatiently, a habit that must be discouraged in this case. 

More information is also available at these sources: 

IDV reference manual (also available under the IDV's Help menu) 

http:/ /www.unidata.ucar.edu/ software/idv/ docs/userguide/toc.html 

Tutorial from the IDV training workshop: 

http:/ /www.unidata.ucar.edu/ software/idv/ docs/workshop/ 

* http://www. uni data. ucar.edu/software/idv/ 
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Tutorial screencasts on YouTube: 

https://www.youtube.com/user /unidatanews/ 

Appendix 1 also introduces the Mapes IDV collection, a free curated set of resources aimed 

at making the IDV more powerful, yet more usable. You install the Mapes IDV collection 
as a Plugin, an extension to Unidata's generic IDV distribution, as shown in Appendix 1 

and in the next section (0.1). The Mapes IDV collection has a prominent section devoted to 
LMT manual materials. These materials are all accessible, free of charge, from any 

machine on the Internet. Users are invited to explore the many other aspects of the collec

tion as well. 

0.1. Install, Launch, Install Plugins, and Relaunch 

INSTALL 

As mentioned above, you can download the IDV from this link: http://www. unidata. ucar. 

edu/software/idv/. After registering with Unidata, download the appropriate version for 

your operating system. Choose the Current Release of the software (presently 5.4). The 

64-bit version is default for Macs, and is strongly recommended for Windows and Linux, 

unless you know for sure that your computer is only running a 32-bit version of these two 

operating systems (note that the memory footprint of the 32-bit version of IDV is limited 

to no greater than 1.5 GB of RAM, which may be insufficient for some of the exercises in 

subsequent chapters of this manual). Follow the prompts to install the IDV; the default 

options are recommended unless you really know what you are doing (if you are installing 
on a Linux machine, you may need to work with your system administrator in order to 

complete the installation). 

LAUNCH 

Once you have the IDV installed, launch it. To do this on a Windows machine, dou

ble-click on the IDV icon which is by default placed on the Desktop during installation. 

You will likely be prompted to allow the IDV to access network ports when it first loads; 

assuming you have Administrator privileges on the computer, go ahead and authorize its 

use on all network interfaces ( see screenshot below). 

Mac users will find IDV in its own subfolder within Applications. Go into that folder and 

double-dick on the IDV icon. If desired, move it to the Dock or Desktop for easier access. 

Linux is a bit more complicated; the recommended use is to note the directory path where 
the IDV is installed; then open up a command window, cd into that directory, and type 

4 / SYNOPTIC-DYNAMIC METEOROLOGY LAB MANUAL 



./runlDV to launch the IDV (for savvy Mac OS users, a similar command-line technique 
can also be used within that operating systems Terminal application). 

Windows Security Alert 

G Windows Firewall has blocked some features of this program 

Windows RrewaD has blocked some features of Java(TM) Platform SE binary on all public, private 
and domain networks. 

d Name: 
~~ - Publisher: 

Java(TM) Platform SE binary 

Orade Corporation 

Path: C: '\program files 'Jdv _s. 3u 1 \jre \bin \java. exe 

Allow Java(TM) Platform SE binary to communicate on these networks: 

~ Domain networks, such as a workplace network 

~ Private networks, such as my home or work network 

~ Public networks, such as those in airports and coffee shops (not recommended 
because these networks often have little or no security) 

What are th~ risks of allowing a program through a firewall? 

Allow access ] [ cancel 

INSTALL PLUGINS 

We recommend the following Plugins to improve the bare IDV installation (note that 
these are separate from the Mapes IDV Collection Plugin that you will install separately). 
To enable these, find the menu item Tools > Plugin Manager in the menu bar 
of either the Dashboard or Map View windows. That will pop up the Plugin 

Manager window, where you will see many choices: 

Nl•MIHelp 
IJ Color Table Editor 
Layout Model Editor 

Projections Manager 
Parameter Alias Editor 
Parameter Defaults Editor 
Parameter Groups Editor 

t,. Plugin Manager 

Unida· 

collection 

Available Plugins 

1±1 Customized. lDVs 

1±1 Displays 

13 Color Tables 

~ GEMP AK Color Tables Color tabl 

~ NCL Color Tables Color tab] 

~ McIDAS Color Tables Color tabl 
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Click the green button with the white cross to the left of each Plugin you want. If you plan 

to install several, select No in the Plug in Confirmation window: You can 
restart later, after adding them all . 

• Plugin Confirmation 

You will need to restart the IDV for this change to take effect 
Do you want to restart? 

No 

Recommended plugins: 

• Color Tables: Install any or all the color tables offered. 

• Maps: Consider US Highways and Roads and US Rivers & Lakes 
• Bug Fixes: Install the Spurious Map Lines Fix Plugin. This is often necessary on com

puters whose graphics cards are based on the AMD/Radeon chipsets. 

The next time you launch IDV, these Plugins will be present. For instance, you can check if 

the color bars you added are present by navigating to the menu item Tools > Color 

Table Edi tor, and examining its Color Tables menu like this: .~. Unidata IDV - Color Table Editor -- default 

File Nll!!ifi■,115•!!!1@•n•+• _!:i~lp __ _ -----------------------
Co Io r Mapes ► [ 

Satellite ► 

Histo 
NCL ► Group 1 ► 

- ~ 

I 

Panoply ► 
Basic ► 
Radar ► 
Misc. ► 
Solid ► --0 

Group 2 ► 

Group 3 ► 

Category: Basic 

- - - .... 3gauss 
11 l :J::1::1 3saw 
II I D CII I amwg 
M I i' M BkBIAqGrYeOrReViWh200 
■ ¾1 W BIAqGrYeOrRe 
= w w BIAqGrYeOrReVi200 
_ _ _ _ _ BIGrYeOrReVi200 
- - - - BIRe 

Dl110Dorlr..--,,u 

All the above Plugins are static files. They are now stored as unchanging files in the user's 

home directory, under the $HOME/.unidata/idv/Defaultldv/ subdirectory on Linux and 

MacOS, or C:\Users\<user name>\.unidata\ subdirectory on Windows. This directory, 

which can be thought of as an IDV Preferences folder, gets created when the user first 
launches the IDV. 

A more dynamic (or self-updating) form of Plugin is the Mapes IDV collection, from this 

manual's coauthor Brian Mapes at the University of Miami. To install the self-updating 
Mapes IDV Collection, follow these two steps carefully. 
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1. Download the two small text files idv. properties and mapes.rbi available at https:// 
www.rsmas.miami.edu/users/bmapes/MapesIDVcollection.html. 

2. Put these files in your IDV preferences folder; as we saw above, this lies in 
. unidata/idv/Defaultidv/ under your home directory. 

Note: By default, some web browsers may append a . html suffix to the filenames. File 
system viewers may hide the . html suffix, and/or hide the . unidata folder, since 
it begins with a ': symbol. For this reason, this simple operation with two small files can be 
tricky, and is most reliably done and checked using terminal commands. For more details, 

see the homepage: http://www.rsmas.miami.edu/users/bmapes/MapesIDVcollection.html. 

RELAUNCH 

You must quit and relaunch the IDV for your Plugins to take effect. In addition, you must 
have an active internet connection for the dynamic resources of the Mapes IDV collection 
Plugin to function properly. If you are offline, the IDV will still launch, but without the 
Mapes IDV resources including bundle and data catalogs and other features mentioned in 

this manual. 

It is possible to work offline, however. IDV bundle files with the . zidv suffix-the heart 
of most of the data exercises in this manual-can be downloaded ahead of time and made 
available as needed on classroom computers; the most current versions can be down
loaded at any time via the web, from the IDV Bundles folder tree of the Mapes repository 

at http://bit.ly/Mapes IDV. Any of these can be opened in the IDV with the Fi 1 e > 

Open menu, allowing one to work without an internet connection. You can download 
the entire current set of IDV bundles comprising the LMT manual materials, using your 

browser, from the menu shown below: 

menu I LMT manual materials 

geodeSystems L.here FIie 
New Folder 

UM Repository for a1 
New FIie 

LMT manual materials o Pick a Type .•• 

Name 
• • Chapter 1 

New IDV Bundle 

O Export Entries 

GI Import Entries 
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0.2. Test-Drive Using a Pre-made IDV Bundle 

The IDV application saves its entire state in an XML file called a "bundle;' with suffix 

.xidv or .zidv. The z in .zidv indicates a zipped file with the actual data included, allowing 

offline use on any machine. Opening a bundle file (for example, with File > Open in 

the menus) will restore the ID V's state that was present when the bundle file was created, 

including all data sources, displays, and even the particular 3D viewpoint. 

Let's illustrate basic IDV use with one of the predefined .zidv bundles from the manual. 

OPEN AN EXAMPLE BUNDLE FROM CHAPTER 1 

As a test drive of the software, this section walks you through a set of actions that will get 

you familiar with the IDV software. The scientific lessons will be deferred to Chapter 1. 

Launch the IDV. You will see two main, separate windows: a Dashboard and a Map 

View window. If you haven't disabled it, an IDV Help Window will also appear. If 
you installed the Mapes IDV collection Plugin correctly, and then you launch IDV while 

online, your Toolbar area on both windows will contain the Mapes IDV collection 

favorites folder, like this: 

File Edit 

~ 
l!J 
ti! 
~ 

View 

Data Tools Help 

I ~ Mapes IDV collection 

Projections 

To open the example bundle for this section, find it in the repository: 

Find LMT bundles: approach 1: 

Left-click the Mapes IDV collection folder. Menus will unfold to reveal 

Classes and Labs> LMT manual materials> Chapter 1 > 

LMT 1 . 2 . Select this item. 

Find LMT bundles: approach 2: 

You can find the same folder tree in the Catalog area of Data Choosers tab of 

the Dashboard. Select General > Catalogs in the sidebar at left, and drill 
down into the Mapes IDV collection folder to find LMT_l.2, as shown in the 
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screen capture below. To launch the bundle, double click it, or highlight it and click the 
Add Source button at the bottom of the Dashboard window. 

• Dashboard 
--- ·~ - ~l :_i;;:;l"'lr@ ~ 

-
file fdit .!lisplays DAta Bundles Iools !!elp 

~ ~ ~~ 1:1 1 Mapes IDV collection 
~ 

I! ~ Quickfinks r " Data Choosers ti Field Selector r Q Displays I 
I! 

9 General 4 
Files ~ < catalogs: jhttp:tiweather.rsmas.miami.edu/repository/entry/showlRSMAS%252FUM%271 • I I Select Ale." 

:• 

l 
URLs :• 
Catalogs 

: : Data Source Type: jrm Feeling Lucky H Directory : 

9 Sat& Radar 9 ~ The Mapes IDV collection . -
Images o- l:;;;J Aggregated dataset links 

Radar 9 G;;J IDV Bundles 

9 Observations o- [;;;] Case study templates 

Point 9 g Classes and Labs 

RAOB 9 g LMT manual materials 

Fronts 9 Q Chapter 1 

! 13 ILMT1.2I 
I I I 

LMT 1.3 MERRA 1979-2015 = 
I 

I 
LMT1.5 

I I 0 LMT1.2RT 
0 LMT1.3 

: : I 0 LMT1.4 : 
0 LMT 1.5 MERRA 1979-2015 

o- I:;';! Chapter2 
o- rg Chapter 3 -

I 
o- ~ Chapter4 
t [;;;J Chapter5 t ~ Chapter6 

1 
Q Chapter 7 

! 
o- (;;;J Chapter 8 
o- I:;';! Contributed 

,: I o- g Structure illustrations 
I 0- I:;;) UM ATM Meso 
I 0- • UM MSC407 lab exercises -- ... 

-: O Show Thumbnail bnages 
: 

Press "'Add Source" to load the selected data 

I Add Source l ~ ~ e 
I 19:42:08 GMT j I - - ·-- ~ 

After either approach: 

Once you have launched the bundle, accept the default suggestions in the Open 

bundle and Zip file data dialog windows shown below. 

• • Open bundle 

Before opening this bundle do you want to: 

II Remove all displays & data 

0 Zip file data 

Where should the data files be written to? 

@ Write to temporary directory 

-

I 

9 Try to add displays to current windows 

Change data paths 

Match Display Region 
0 Write to: l..._ ________________ __,L_se_ tec_t_D_if_ect_ o_ry __ --' 

Don't show this window again 

Cancel 

D !0on1 show this again! 

0 1 cancel 

Do not check the Don't show this again box. Some exercises involving succes

sive additions of bundles of displays will become impossible. If this is done inadvertently, 

II 
I< 
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it can be restored by clicking on Edit > Preferences; look under the General 

properties tab: 

~I User Preferences 

General f Fonnats & Data f View Available Choosers r Available Displays r System 

General Preferences 

General: 

0 Show Help Tip Dialog On Start 

D Confinn Before Exiting 

~ Show Dashboard On Start 

D Show Hidden Files in File Chooser 

~ Show Toolbar in Windows 

When Opening a Bundle: 

~ 

~ !Prompt user to remove displays and dat, 

~ Remove au displays and data sources 

~ Ask where to put zipped data files 

Resource Sitepath: 

External Editor: 

Look & Feet I Metal I• I 

Display Controls: 

~ Show Windows when they are created 

~ Show icons in legend 

~ Use Fast Rendering 

0 Auto-select data when loading a template 

When Display Control Window is Closed: 

0 Remove the display 

D Remove standalone displays 

SelectFile.-

In a few moments, your Map View window will have a Legend on its right-hand 

side, with many displays indicated, similar to that shown below. 

File 

~ 
~ 
(jl I View Projections 

11 ,
Iii 
~ 
[gJ 
r 
( 

•11 l 
I - -\-ir- ·\ 

~ ... 
t 
i 

~ 
C 

' 

/ 

\ ✓ 

,.. ,, \ 

t 
() 

"\ / 

'/ 
'' 

' 

\ 
)< 

'\ ,, / 

/ ' 

'( 

' -< 
/ ' 

I 
'--.., I ,, 

/ ' 

Un!_data IDV - Map View - On_e Pane 

Mapes IOV coll•ctlon W PSD Bundles 

( 01/24/ 14 12:00 UTC 
• Legend 

: ) ~l!!][fllffiIE[GI ► 8 ~ Vertical Cross Sections 
Cl 

_, 
• - - - I 

' / 
"\ I 

'( 

- ✓ ' 

'I.._ 
I ..._ 

,- -

I 
I 

B g dTdv - Contour ems$ Secti 0 B 

-, s 611 dJdy - Contour Crg:;s sect! & B 

B ~ theta - Cgntour CM$$ Secti a B 

~w00aem RJ~P J!•R O B 

B O wjnd<peed - 1,0,urface 
Valua:40111/S 

B O dJdy - ISP<urface 
Valuoc.DlS 0.001 lt.m-l 

80 

.0714 

s D dTdy - isosurface 
Value: -.DlS 0.001 K.m-l 

.0714 

r- B 

".'] fj 

r~ Ei 

U· C9fflPO.n,m OT WIDA ,~o ~ Ei 

J883.7 MB/5.405 CB jLatitude: 49.7 Longitude: -52.8 Altitude: 0.0 m 

ii .J 

As a brief tour of the possibilities that this IDV bundle presents to you, try the following 
actions. 
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A 3-button mouse with scroll wheel is recommended to access the IDV's rich suite of fea

tures. However, some of the same functionality exists in two-fingered swipes on trackpads, 
with or without the control key depressed, or using arrow keys. Under the Help 

menu, you will see a special section on panning, zooming and rotating. 

• Under 3D Surface, check the box for the green windspeed - Isosurface 

display. The jet stream becomes visible. 

• Click and hold the right mouse button over the map display, and move the mouse 

around. You will see 3D motion of the display volume, revealing the cross sections. 

(Left and right arrow keys or two-fingered gestures with and without control will 
perform the same action.) 

• Repeat the above mouse action with the control key depressed. This time the 

display volume will pan rather than rotate. Alternately, green arrows at the left edge of 
the view window will pan the view manually. 

• Zoom in and out with the mouse scroll wheel, or use the magnifying glass icon . A 

vertical two-finger gesture on a trackpad also does this. 

• Jump to a west view by clicking this blue-sided cube icon #9 on the left edge of the 

window. Use 3D rotation (holding the right mouse button while moving the mouse) to 

see how this west view fits into the 3D scene. 

• Use the blue-topped cube ~ or Home icon to return to top view. 

• In the Legend, minimize or expand the details of various displays, or groups of 

displays, with the colored El and l±I squares to the left of the visibility checkboxes. 

Legend 

13 ~ Vertical Cross Sections 

0 1 

• A display can be eliminated entirely with the trashcan icon. 

Additional basic operations for interacting with the view and the displays are also 

accessible using the icons along the left-hand edge of the window. Explore them. These 
and many other aspects of the IDV are documented under the He 1 p menu. 

A WINDOWS OPERATING SYSTEM-SPECIFIC MISBEHAVIOR 

You may occasionally notice that your IDV display window goes "blank" if on a computer 

running the Windows operating system: 
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Should this occur, try left-clicking in the blank region, or simply resize the window 

slightly by clicking anywhere on the outer periphery of the Map View pane and drag to 
slightly resize. The display should reappear. 

ADD A NEW DISPLAY 

• Create a Blue Marble image, by clicking the (f,{J icon in the toolbar. Notice that the new 
display appears under Maps in the Legend of the Map View window. Expand 

the Maps menu if necessary by clicking on the plus sign to its left, and then use the 
checkbox to turn its visibility on or off, whichever you prefer. 

• To add a more advanced display, locate the Dashboard window. If you have lost or 

closed it, re-open or create a fresh one by clicking on this gamepad ~ icon in the 
upper left corner of the Map View window. Click the Field Selector tab 

near the top of the Dashboard window. You will see Data Sources listed 
along the left edge of the window. Select GFS CONUS 95km. Click the unpacking 

icon next to 3D grid (a small triangle or knob-like symbol), successively, until you 

are able to select Temperature @ Isobaric surface. 

••• Dashboard 

File Edit Displays Data Tools Help 

~ - ~~ -I @ ~ ~~ ~ i/ ~ ~ D Mapes IDV collection 

t, Quicklinks I} Data Choosers 

Data Sources: Fields 

Formulas j Y 3D grid 

► GFS CONUS 95km 20140 ► Momentum 

Y Temperature 

► Derived 

~ Temperature @ Isobaric surface 

f 23:38:17 UTC 

Q Displays 

O. Displays 

Y Plan Views 

Contour Plan View 

Color-Filled Contour Plan View 

Color- Shaded Plan View 

Times MTl1 Region Data Samplin~ Settings 

All Levels 

10000 Pa 
15000 Pa 
20000 Pa 
25000 Pa 
30000 Pa 
40000 Pa 
50000 Pa 
70000 Pa 
85000 Pa 
100000 Pa 

Create Display 

lllll 

At that stage, choices appear in the Displays area at right. Try the following: 

• Displays selector: Select Color-Shaded Plan View under the Plan 

Views tab, a safe choice (contours have many options which can make a display fail 
to be visible). 

• Ti mes tab: there is only one time in this case. 
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• Level tab: choose 100000 Pa (or 1000 hPa; this is near sea level). 

• Region tab: choose Match Display Region in the dropdown menu. 

• Data Sampling tab: take no action to accept the default (full resolution). 
• Settings tab: take no action. 

• Create Display is the button at the bottom of the Dashboard. Click it. 

Your Map View windowwillnowhaveanew Temperature isobaric display, 
as shown below. 

file £.dit Jlisplays D!l1a Ioots !felp 

~ 

~ ' 
\ I 

/ \ 

I \ ' 

/ ' \ \ Cl 

' ' 

"\. I 

'-I 
I"\. 
I "\. 

' ' ', 
'\ I 

•, Ln,~, 
1 Tempe 
✓ 
I'-

P.tapes IDV collection P SO Bundles 

I 

\ 

I 

I 
\ 

\ 

't 
\ .... ' 

\ 

I 
\ 

\ 

In the Legend, find your new display called Temperature_isobaric, under 

Plan Views. Confirm it by unchecking and rechecking its visibility checkbox. Now 
click the blue hyperlink itself (Temperature isobaric ... ). A Display Control 

window will appear, either as a tab in the Dashboard window if you still have that 

open, or otherwise as a standalone window. 

Try the following: 

• Color Table: Click the Temperature button to choose a new color table. You 

can also try changing the range of the color table, as the default range of -90 to +45 is 
rather wide. 

• Smoothing: Apply a horizontal smoothing, such as Gaussian weighted, and 
notice how the display changes. 

INTRODUCTION: ORIENTATION AND SOFTWARE / 13 



. .... . Dashboard 

File Edit Displays Data Tools _He_l_p ____________________ _ 

~ [_ ~~ w ·-9! 531 .f do Mapes IDV collection 

& Quicklinks M Data Choosers t".l Field Selector 

13~ Viewl File Edit View Help _____________________ _ 

Default Background Maps 

u-component of wind 

u-component of wind i. 

dTdy - lsosurface 

dTdy - lsosurface 

windspeed - lsosurface I 
theta - Contour Cross S. I 
dTdy - Contour Cross S. 

dTd - Contour Cross S. I 
Temperature isobaric . ► 

23:40:04 UTC 

Color Table: 

Visible Range: 

Texture Quality: 

Smoothing: 

Levels: 

Display: 

~ G;J?'ti (O) B 

Temperature -9o _ _ ___ __ ::=)4s celsius 

Change From: -5.3 To: 33.6 

High Medium Low 

None -Factor: 6 

100000 '• ... .. Current level: 100000 Pa Cycle 

Shade Colors: Mode: Solid -Point Size: 1.0 

IIIll 

• Levels: Change to 25000 (the 250-hPa level, typically in the upper troposphere). In 

3D views, you will see that this is close to the level of the mean jet stream. 
• On the Map View window's Legend, check the box to make the green 

windspeed- I sosurf ace display of the jet stream visible. Now rotate the display 

in 3D by holding down the right mouse button as you move the mouse, to verify that 

your 250 hPa Temperature display plane is at about the same altitude as the jet stream. 

• Add a Color Scale. To do this, from the Edit menu of the Display Control 

window, select Properties ... A new window will pop up. One of its tabs is 

Color Scale. Select Visible and adjust as desired, then click Apply or OK: 

e Properties -- T e~ peraturejsobaric - Color-Shaded 'Plan View; Level: 25000 Pa 

/ Settings Color Sca1e Times Spatial Subset 

Visible: ~ 

PoSffioO: I: ~ nn A • 

Labels: ~ Visible 

• Capture an image or movie: In the Map View window's display area, find the 

View menu. Select Capture > Image. Set the file name suffix to determine the 
graphical image type, such as .jpg or . png. 
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SAVE AND RESTORE YOUR SESSION 

• Save your IDV session state as a bundle file called test. xidv, using the File > 

Save As ... menu, or the floppy disk icon ::: in the toolbar. 

• Erase your displays and data with the scissors icon, or only the displays using the eraser 
icon (mouse-hover will show what the icons do). Or, quit and restart the IDV. 

Quit the IDV by either clicking on the icon; selecting File > Exit; or simply 
by closing the Map View window itself. Restart IDV just as you started it before. 

• Now, open test.xidv from the File > Open menu. Or, find it and other recently 
used files in the Dashboard's Quicklinks top tab, in the History sub-tab 
on the left hand side. 

Your session should appear exactly as it was when you saved it. (Note: In this case, this 
only works because the data are still in the temporary directory they were unzipped into.) 

For additional IDV skill building, with detailed step-by-step screenshot instructions like 
the above, try Exercise 3.4. 

0.3. Key Points of This Chapter 

We hope this tour has shown you the professional, "workshop" -like usage style of the 
IDV. More advice on working with the IDV is expressed in the orientation discussion and 
linked materials in Appendix 1. 

You can now see why using collections of pre-built bundles of displays is so much easier 
than the arduous process of creating your own displays from scratch. Perhaps the exer
cise showed you the need for caution too. For instance, when you changed the Color 
Tab 1 e on your display, there was no "Back" or "Undo" button, a common feature in 

commercial software packages such as Microsoft Office or Photoshop ! If you had created 
a carefully customized color table, and then you changed it, all that prior effort would be 

lost. If you don't save your bundle, manually, every time you add valuable effort, your work 
can be lost with a slip of the mouse. The wry advice of an author's wood and metal shop 
teacher applies: "Measure twice, cut once"-just as you would with real workshop tools. 

You can surely see how students (and instructors!) accustomed to operating mass-market 
commercial software and apps might find the IDV frustrating at first. 

With this cautionary advice in mind, we hope you will agree that IDV's power in making 

3D meteorological visualizations is worth the care and effort required to teach and learn 
well with it. 
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Appendix 1: Further IDV Orientation Discussion and Materials 

A PowerPoint presentation with further orientation material is available at http:// 
weather.rsmas.miami.edu/repository/ entry/show? entryid=dd95b65c-09a5-43a5-9f 44-
da5243e302f 4 or its shortened link http://bit.ly/2m9zS9s. 

Appendix 2: Case Suggestions for Historical Storm Analyses 

In some Optional: exercises, displays identical to those in the exercise can readily be 
generated for use on historical cases, using free online archival data sources. Bundles with 
the form LMT _ X . Y _ MERRA _ 19 7 9 - 2015 mark such opportunities. 

Below is a very partial and arbitrary listing of past storm cases that readers could view: 

Over the United States: 

• Inauguration Day storm of 1993 (Pacific Northwest, 20 January 1993) 
• "Storm of the Century" https:/ /en.wikipedia.org/wiki/1993 Storm of the Century 

(12-15 March 1993) 

• The 10 November 1998 storm examined in detail in Chapter 8 of the excellent text
book of Wallace and Hobbs (2006); utilized in exercise 5.3 

• Superstorm Sandy (October 2012) 

Beyond the United States: 

• European storm Xynthia (https:/ /en.wikipedia.org/wiki/Cyclone Xynthia, 27 Feb-1 
Mar 2010) 

• The extratropical transition (ET) event following STY Nuri in the western Pacific 
https://en.wikipedia.org/wiki/Typhoon Nuri (2014) (20 October-IO November 2014) 

Many more cases of interest could be found, for instance in Asia or the Southern Hemi
sphere. Cases that cross the dateline will unfortunately not be possible. If a community 
of readers takes the time to create high-quality case studies, we will gladly publish (host) 
those files in a repository. To contribute, save your analysis bundle as a zipped (.zidv) file, 
and contact mapes (at) miami.edu for options to add it to the repository. A folder called 
Contributed has been created in the LMT materials area, in preparation for this hoped-for 
outcome. 
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